Applies To:
Call2Teams - Customers
Overview
When attempting a Sync process, the following error appears:
Sync Error: Cannot modify the parameter: OnPremLineURI because it is restricted for the user service plan
Issue
This error is caused by a conflict in licensing.
Causes
There are several scenarios that can cause this issue:
- Where a recently licensed user has a number applied, but Microsoft have not yet updated the user database to acknowledge the phone system's capability.
- Where a number is being moved to a new user, from a user whose license has been recently removed. Microsoft produce this error as the act of removing a number from an unlicensed user is not needed.
- The user has been given the Virtual Phone System License rather than the regular Phone System License.
- The user has an existing Microsoft calling plan.
Solutions
Wait a short time - up to an hour, and attempt to Sync again. This gives Microsoft time to propagate the changes.
If the user has a Virtual Phone System License, amend this so that they have a Phone System License. Run another Sync.
Note: The Virtual Phone System license should be reserved for Service/Resource Accounts.
If the user has an existing Microsoft calling plan, this issue can only occur when an attempt is made to Sync in Large Tenant Mode. Remove the MS Calling plan in order to Sync the affected user.