Applies to

Call2Teams Customers


Issue

On the service portal, the following error message appears below the Sync Now button: 

"Setup partially complete, click Sync Now. 2 domains are not ready in Office 365"


Cause

On occasion the Microsoft domain activation process fails to properly enable the voice routing domains added to the customer tenant.


Normally this issue resolves after a period of time, often this can be several hours. 

The setup can be competed by clicking the Sync Now button.


Solution

Where the domain validation failure message described above persists for an extended period (over 24 hour) then customers can resolve it by re-initialising the process with new domains for validation.


Note: this process is service affecting and will result in the inability to make and receive calls through the connector whilst the update is taking place. 

Note: Read the whole of this article before following the advice given. See the Accounts With Existing Customers section.


This process may take some time so customers are advised to schedule a maintenance downtime window of several hours in an off-peak time slot.


Follow the steps below to restart the process:

  1. In the Services Tab, delete the Teams service by clicking the 'Trash' Icon:
  2. In the customer's Microsoft 365 portal at https://admin.microsoft.com/ delete the domains belonging to the service - there should be at least two.
  3. The service is now ready to be set up again with new domains.
  4. Find and delete any user(s) called "Temporary Domain Voice Activation User" in the Microsoft 365 user admin portal:
     https://admin.microsoft.com/Adminportal/Home?source=applauncher#/users 
  5. In the Services Teams tab, click the Enable Service button to start the domain setup again with new domains assigned:

The Enable Service function typically takes around 15 minutes to complete but can take longer depending on Microsoft's service.


Note for customers with existing users


Existing customers will become disconnected and may require manual re-connection/configuration if the above process is performed.


While the user list may have missing information, the Sync process may be able to match up unattached parts. This means a complete re-configuration may not be needed:


Note: Although the SIP or Trunk user part remains, the user information is missing and has to be selected from the list of Teams users, so customers are advised keep a record of this prior to the deletion of the Teams Service

The Import Users tool also can perform this as a bulk operation if a large number of users require configuration.