Applies To
Customers/Partners
Overview
Running a Sync fails with the following error when attempting to set User Calling policy:
<01:39> PS1> Grant-CsOnlineVoiceRoutingPolicy -Identity "a.user@domain.com" -PolicyName "Call2Teams-USW"
<01:39> ERROR: PSERROR1> [ClientError] : User policy update failed with message: The user was not provisioned successfully.
Parameter name: 091a69e3-c730-4a67-bb64-59b43caa5447
Cause
The most likely cause of this is that the Microsoft configuration for the user has not fully completed, or has completed with some issues.
Solution
Following these steps:
- Fully remove the user from the service portal
- Perform a full Sync
- Add the user again
- Perform another full Sync
Escalation
If the issue persists then follow these steps:
- Fully remove the user from the service portal
- Remove the user from the MS Tenancy
- Perform a full Sync
- Add the user to the MS Tenancy again
- Perform another full Sync
- Add the user to the service portal again
- Perform a third full sync.